Prepared by - Jaswinder Singh
Linkedin

UBA Import Users using AD/LDAP

*Lab Deployment & Software details™®

. .
Host Deployment
u < > u UBA

QRadar A-I-O
Console

QRadar AppHost

LDAP/LDAP(TLS) >

L | |
Active Directory

QRadar 7.4.3 All-in-One Console

QRadar 7.4.3 APPHOST

WIndows Server 2019

VirtualBox

Prerequisites for user imports to UBA using LDAP/AD

LDAP/AD - <IP or Hosthame>

Username - <Bind DN Format>

Password

Base DN

Filter - (&(sAMAccountName="*)(samAccountType=805306368))
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1. Creating User for UBA authentication

1.1. Select Start->Windows Administrative Tools->Active DIrectory Users and

Computers
)

- 4

Recycle Bin

Windows Server

B >

‘Windows
PowerShell ISE

Firefox

Search

Server Manager

Settings e ey
‘Windows
Administrativ... Task Manager Control Panel

Windows Accessories
Windows Administrative Tools - % iE] ™
Active Directory Administrative Ce... Event Viewer
Active Directory Domains and Trusts
Active Directory Module for Windo...
Active Directory Sites and Services
Active Directory Users and Compu...
ADSI Edit

Component Services

vomgLvymE"mioPY o

Windows Server 2019 Standard Evaluation
Computer Management

ko)

sit S m o

us 31-07-2022

Hoovm., fO ER ~@ R gaw

1.2. Select View->Advanced Feature.(ignore this step if already selected)

o]

Recycle Bin
] Active Directory Users and Computers
*s File Action View Help

=) &= = |2 Add/Remove Columns...
Firefox -~
] Active Direc Large lcons
Saved Q

~ 3 kalsidc.l . ntainer for up...
Built

h
Small Icons

Corr ® Detail ntainer for do...

Dorr ntainer for sec...
E Users, Contacts, Groups, and Computers as containers

Ma Advanced Features

ntainer for ma...

ntainer for up...
User Filter Options...

Customize...

< >

Enables/disables advanced features and objects

Windows Server 2019 Standard Evaluation

1413
31-07-2022
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1.3.

1.4.
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Create new user by Right Click on Users->New->User

&wn

+

] Active Directory Users and Computers

File

Action

View Help

e 2 & 0XRE S Hem| R w @Y

2 a8

Linkedin

Active Directory Users and Com
=] Saved Queries

~ 4 kalsidc.local

7 Builtin
Computers
Domain Controllers

WL

u,

Keys
LostAndFound

NN RNy

Program Data

ForeignSecurityPrincipal:

Managed Service Accour

Name

&, Administrator

52 Allowed RO...

2, Cert Publish...
&2, Cloneable D...
&2, Denied ROD...

2 DnsAdmins

52 DnsUpdateP...

5% Domain Ad...
2 Domain Co...

Type
User

Security Group...
Security Group...
Security Group...
Security Group...
Security Group...
Security Group...
Security Group...
Security Group...

Description

Built-in account for ad...

Members in this group c...
Members of this group ...
Members of this group t...
Members in this group c...
DNS Administrators Gro...
DNS clients who are per...
Designated administrato...
All workstations and ser...

| System 2 Domain Con... Security Group... All domain controllers i...
7 Use 2% n-i- Gue... Security Group... All domain guests
= NTC Delegate Control... Jsers Security Group... All domain users
= TPN Find... = A.. Security Group... Designated administrato...
New > Computer
All Tasks > Contact c
View > Group
InetOrgPerson
e msDS-KeyCredential
R msDS-ResourcePropertyList
Properties msDS-ShadowPrincipalContainer
Help mslmaging-PSPs
83, RAS and MSMQ Queue Alias L
2 Printer
2, Schema Shared Folder p...
2 : User
< >
Creates a new item in this container. Firefox

Create a user with any name - In our case we used username”qradaruba”.
Without any special privilege

MNew Object - User

2

First name:
Last name:

Full name:

Create in:

kalsidc local/Users

ntials: [ |

User logon name:

I gradaruba

|
|

l gradaruba I @k alsidc local ~
User logon name (pre-Windows 2000):
lKALSIDCD\ I |qradamba |

< Back
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1.5.

1.6.
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Select the properties option of user “qradaruba”

Linkedin

8 WINAD_SERVER [Running] - O o
] Active Directory Users and Computers —
File Action View Help
= 2@ FO0XEDE= Hm| 2 ey 2
=2 AFtlve ectory Users and Com/|| Name Type Description
=] Saved Queries &, Administrator User Built-in account for ad...
v & "?'s;:fi;l‘i’:" 2 Allowed RO... Security Group... Members in this group c...
2 Computers £, Cert Publish... Security Group... Members of this group ...
B Dormbin G c D... Security Group... Members of this group t...
| ForeignSecurityPrincipal] | 2 Denied ROD < e
] Keys 2 DnsAdmins B istrators Gro.
| LostAndFound &2, DnsUpdate Add to a group... who are p
] Managed Service Accour | 5% Domain Ad Name N ini
Program Data &2, Domain Co Disable Account ions and ser...
| System £ Domain Co Reset Password... controllers i...
Users £#2 Domain Gu SMove. guests
-] NTDS Quotas 5% Domain Us. users
=] TPM Devices &2 Enterprise £ e administrato...
2 Enterprise k Send Mail  this group ...
£ Enterprise F All Tasks , 7 this group ...
2, Group Polic this group c...
2. Guest Cut Sunt for gue...
i Delete
2, Key Admin e ? this group ...
2, krbtgt tion Center ...
52 Protected L Flalp * this group
2 T,
2 RAS and IAS ... Security Group... Servers in this group can...
User
2 Read-only D... Security Group... Members of this group ...
2 Schema Ad... Security Group... Designated administrato...
User
< >
Displays Help for the current selection.
Copy the username in Bind DN format
py :
— —  — H  —
E.g., CN=qradaruba,CN=Users,DC=kalsidc,DC=local
B win AD serveR o VM Virtual o
= =]

File Action View Help

e 2 &0 XES= Hem| 2 aEavYd

] Active Directory Users and Com
| Saved Queries
~ 4 kalsidc.local
Builtin
Computers
Domain Controllers
“| ForeignSecurityPrincipal:
] Keys
LostAndFound
7] Managed Service Accour
Program Data
| System
| Users
“| NTDS Quotas
TPM Devices

Name
&, Administrator
2 Allowed RO...
2 Cert Publish...
% Cloneable D...
5% Denied ROD...
2 DnsAdmins
2 DnsUpdateP...

Domain Ad...
£#2 Domain Co...
£2 Domain Con...
2 Domain Gue...
5% Domain Users
52 Enterprise A,
% Enterprise K...
2 Enterprise R...
&2 Group Polic...
2, Guest

2 Key Admins
2, krbtgt

&2 Protected Us...
& gradaruba

2 RAS and IAS ...
2

2 Read-only D...
22 Schema Ad...

qradaruba Properties

? x

Password Replication ~ Dialin  Object

Environment Sessions Remote control
General  Address  Account  Profle  Telephones  Organization
Remote Desktop Services Profile COM-~ Agtribute Editor
Atributes.
Attribute Value ~
department <not set>
departmentNumber <not set>
description <not set>
desktopProfile <not set>
destinationindicator <not set>
displayName aradaruba
displayName Printable <not set.
distingui | iba.CN=Users.DC=kalsidc.DC=lo |
division ot sets
dSASignature <not set>
dSCorePropagationD... 7/31/2022 2:28:32 PM Pacific Daylight Time
dynamicLDAPServer  <not set>
employeelD <not set>
employeeNumber <not set> v
< >
Edit Filter
Cancel Aoply Help
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1.7. Copy the sAMAccountType
E.g., (sSAMAccountType=805306368)

]

qradaruba Properties ? x
Recycle Bin
Published Certificates ~Member Of  Password Replication ~ Dialin  Object
— Security Environment Sessions Remote control
- General  Address  Account  Profle  Telephones  Organization
* File Action View Help Remote Desktop Services Profile COM+ Attribute Editor
|~ - . - -
Firefox = =z £ 0 Attributes
] Active Directory Users and Attribute
Saved Queries
= revision
~ &3 kalsidc.local ad
Builtin

roomNumber

Computers
Domain Controllers
ForeignSecurityPrin
Keys
LostAndFound securityldentifier
Managed Service Ac| seeAlso

Program Data senalNumber
System servicePrincipalName
= shadow Expire

NTDS Quotas shadowFlag

TPM Devices shadowlnactive

ndows Se r 2019 Standard Evaluation
Windows License valid for 165 da

39°C NG 1418
e @y T o

Mostly sunny

2. Configuring User Import in QRadar using AD Authentication
21. Login to QRadar->Admin Tab->User Import

QRad:
« > C O

IBM QRadar

m Time: 6:18 AM

Dashboard LogAcivity ~ NetworkAclvly ~ Assels  Reporls  Risks  Vuinerabiies  Adm Puise

Admin © Deploy Changes  Advanced v s

» System Configuration

‘ 1) There are no changes to deploy,

» Data Sources @
Device Import
Remote Networks and
Services Configuration
Try it out QRadar Log Source Management
> Apps -
QRadar Log Source
Management

Pulse - Dashboard
a

Pulse - Dashboard

Pulse - Threat Globe

|

Threat Globe
Configuration

User Analytics

9 P
o] £ = o 8

UBA Settings User Import Rules and Tuning Help and Support Machine Learning
setngs
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2.2. Select Add

O @ https//192.168.1.136/console/plugins/1065/app_proxy/user_import/ing

Import Configurations

No user import configuration. Click the add button to add user data from either LDAP or QRadar Reference Table.

User Import

1419
07-2022

® % qae ,

2.3. Select LDAP/AD Option

) User Import — Morzilla Firefox (Pri

O & https//192.168.1.136,

User Import > Add

Which source do you want to import user data from?

O

o LDAP/AD |
(] 2

LDAP/AD

Reference table CSV file

No reference tables found.

B O OO M 3 ~@ [Ldsﬁ B g
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2.4. Enter the required details gathered from step 1.6. And 1.7.

® User Import

er_import/index

O G https//192.168.1.136/cor PP_proxy

User Import > Add

@ 1o serverconiguration LDAP server configuration

’ Enter the LDAP server information to retrieve user data. Before going to the next step, click Test connection.
2 ) Otherimport settings

Protocol LDAP server host * (O Port *
A sample LDAP will appear after you test the connection

3 | Summary Idap:// v | 389

Enter a valid IP address or hostname.

Username (Bind DN)

Password

Advanced settings

2.5. Validate below details

*

% https://192.168.1.136/console/plugins/1065/app_proxy/user_import/index
9 pp_p P

User Import > Add

@ 1o serverconiguraton LDAP server configuration

e ot et Enter the LDAP server information to retrieve user data. Before going to the next step, click Test connection.
2 her import settings

Protocol LDAP server host * Port *
© A sample LDAP will appear after you test the connection

3 | Summary Idap:// v 192.168.1.129 389

Username (Bind DN)

cn=qradaruba,cn=Users,cn=kalsidc,cn=local

Password

cesecces

Advanced settings

Base DN (D

cn=Users,cn=kalsidc,cn=local

Filter (O

(&(sAMAccountName=*)(samAccountType=805306368))

Certificate O

2, Click to upload the certificate file for the root certificate authority. File size is limited to 10 KB.

Paged results

@ O»
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2.6. Run test connection

5]

O & https//192.168.1.136/cor >lugins/1065/app_proxy/user_import/index

User Import > Add

@ 1orpserver coniguraton LDAP server configuration
2) Other importscttings Enter the LDAP server information to retrieve user data. Before going to the next step, click Test connection.
Protocol LDAP server host * (i) Port *
3 Summary daps/ v 1921681129 389 Attribute Samples
Username (Bind DN) on krbtgt
CN=gradaruba,CN=Users,DC=kalsidc,DC=local description Key Distribution Center Service Accou...
Password distinguishedName CN=krbtgt,CN=Users,DC=kalsidc,0C
seseecee dn CN=krbtgt,CN=Users,DC=kalsidc,DC=..
Advanced settings memberOf CN=Denied RODC Password Replicati...
BaseON O name Krbtgt .
N-Users DC-KalsidenC-tocal objectCategory CN=Person,CN=Schema,CN=Configur..
fiter © objectClass top person organizationalPerson user
. Type-B05306368) objectGUID {01936ba0-94f3-415e-a9¢2-98c7d0... no:
Certificate (O objectSid 5$-1-5-21-504765285-2924659266-...
1, Click to upload the certificate file for the root certificate authority. File size is limited to 10 KB. sAMAccountName kebtgt
servicePrincipalName kadmin/changepw

Paged results

Number of attibutes: 12

2.7. After successful test, choose the required settings

"

% https://192.168.1.136/console/plugins/1065/app_proxy/user_import/index
pp_p

User Import > Add

@ oae server configuration Other import settings

) ! Set the import configuration data from the LDAP server.
° Other import settings

N . Configuration name *
’ SuRRary 192.168.1.129

Synchronize reference table

Polling interval *
24 Hours

0 for mar orset ling int th value betw d 864C

Retrieval limit *
500,000 Users

ter an integer val and 5000€

Frevious m

@ N e
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2.8. Review the summary of connection & Save.

(5]

O G https//192.168.1.136/con: gins sxy/user_import/index

User Import > Add

° LDAP server configuration Summary
Review the settings and click Save.
° Other import settings
Configuration name 192.168.1.129

@ sy

Data source config

Data source type LDAP

URL Idap://192.168.1.129:389

Base DN CN=Users,DC=Kalsidc,DC=local

Filter (&(sAMAccountName=*)(samAccountType=805306368))
Username (Bind DN) CN=qradaruba,CN=Users,DC=kalsidc,DC=local

Paged results Yes

Import settings
Polling interval 24
Retrieval limit 500,000

Frevious m

@ N Dow

IN

2.9. Connection is ready for AD. Select Start option and wait for several
minutes.

»
O & https//192.168.1.136/console/plugins/1065/app_proxy/user_import/index
User Import
Import Configurations n

192.168.1.129
Retrieval limit 500,000 User extracted o
Polling intorval 2 Last poll date
Last edited 07/31/2022 06:34 AM Last poll status Queued

~@ W Ouw
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2.10.

(5]

O & https//192.168.1.136,

User Import

proxy/user_import/index

Import Configurations

Wait for “ldle” result for Last poll status
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s m

192.168.1.129

Retrieval limit 500,000

Polling interval 2

Last edited 07/31/2022 06:34 AM

User extracted
Last poll date

Last poll status

8
07/31/2022 06:38 AM

Queued

ENG
N &

2.11.

Log Activity

Overview RS

User Import activity completed.

QO G o & hitps//192.168.1.136,

Network Activity Vuinerabilties

Monitored users

8

High risk users

0

Monitored users

0% of monitored users

Username Recent Overallrisk
O Jaswinder Singh 0 0
O TESTO1 0 [
O  CN=Administrat.. 0 o

Built-in account for admin.

O CN=krbtgt,CN: 0 0

Key Distribution Center Se.

O  TESTO2 0 _— 0
O gradaruba 0 0
O  TESTO3 0 [
O  CN=Guest,CN=Us... 0 o

Built-in account for guest

o

o

o

o

Recent offenses

Users discovered from events

0% of monitored users

No recent sense offen:

Users imported from directory

Active analytics
Rules: 9 of 206
Machine learning

100% of monitored users

System score

No data is available.

Risk category breakdown (Last hour)

No data is available.

Jul30-3ul31 B

ENG
N &
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